PDA

View Full Version : Need help with midi problem



chrissk21
04-13-2017, 06:23 AM
This one has me completely stumped - I use a Casio PX-5S as a controller and live instrument. The internal keyboard sounds are functioning great. I've got plenty of velocity curve to play with and can produce quite expressive sounds on a slightly tweaked Concert Piano Stage Setting.

However, I've recently noticed that the sounds produce by Reason 6.5.3 (some synths and a few pianos) when being controlled by my PX-5S feel muffled and muted as compared to when I use a different controller. And, oddly, when I hold down the sustain pedal, the sounds in Reason return to being clear, bright, and significantly louder.

Here's what I've tried:
1. I tried numerous different custom and purchased patches in Reason. They all seem to be exhibiting this problem.
2. I've tried a number of different stage settings on the PX-5S to see if it was something I accidentally triggered - nope. It occurs on a lot of them, even ones I didn't build or fiddle with.
3. I've tried different USB cables. Still does this.
4. I've disabled the internal sounds (local control) on the PX-5S. Didn't help.
5. I've disabled High Resolution midi Output on the PX-5S. Didn't help.
6. I did a full factory reset on the PX-5S. Didn't help.
7. Used MidiOx on my PC to examine the midi output and velocity values coming from the PX5S. Everything seems to be performing perfectly. All the same with or without the sustain pedal.
8. I set up a demo install of PianoTeq on my PC to test the PX-5S. It performed perfectly. No variance in volume or response like with reason.
9. I installed a Reason 9 demo to see if the old version was causing the problem. Nope.

Any ideas? I can still use the PX-5S to control Synths and Pads as they are much easier to control with longer attacks, but this problem has made playing a midi piano of any kind impossible.

Thank you all in advance,

Chrissk21

Matt
04-13-2017, 04:06 PM
Have you tried to play any of those patches using the build in keyboard in Reason? I would try this and if they play fine it is your midi controller or the way you have it hooked up or both.

Osmose
04-17-2017, 11:06 AM
Like matt said .and if it is indeed your controller, screw it open and clear any dist and grease out. Electronics like to gather quite a few of it over time..